Issue
It is possible to change the status of another user when you click on the status icon in the team inbox overview. Sometimes, however, this is not possible and the status won't change without any error messages.
Products
Mobile Service Cloud
Cause
This behavior is caused by the user not being connected to a channel within the webstore settings. When no channels are selected, you are unable to change the status of the user.
Resolution
Add the users to one or more channels within the webstore settings. Follow the next steps to add the user to a channel:
Step 1
Navigate to the webstore settings and select the webstore this users should be a part of:
Step 2
Scroll to the bottom of the webstore settings page and select one or more channels for the users we can't change the status of. Ones done, you should be able to change the status of the user in the inbox team overview.